Issue with account opening
Incident Report for Monese
Resolved
This issue has now been resolved.
Posted Mar 25, 2020 - 16:04 GMT
Investigating
We’re currently investigating a technical issue with one of our partners, which is affecting account opening for some customers. If you already have a Monese account, you won’t be affected. We’re working to fix this as soon as possible!
Posted Mar 23, 2020 - 19:15 GMT
This incident affected: Account opening.