Issue affecting Instant Top-Ups
Incident Report for Monese
Resolved
We can confirm that the issue has been resolved and Instant Top-Ups are now working again. We apologise for any inconvenience caused.
Posted 6 months ago. Jan 29, 2019 - 14:45 GMT
Identified
We are currently investigating an issue whereby customers are unable to add money to their accounts via Instant Top-Up. We will provide an update once this is resolved.
Posted 6 months ago. Jan 29, 2019 - 14:27 GMT
This incident affected: Payments.