Issue affecting new account opening
Incident Report for Monese
Resolved
We can confirm that the issue affecting account opening has been resolved, and new customers should be able to continue opening their Monese accounts. We apologise for any inconvenience caused.
Posted Sep 24, 2019 - 16:38 BST
Investigating
We are currently investigating an issue that is preventing customers from opening an account with Monese. We are looking to fix this issue as soon as possible and apologise for any inconvenience caused.
Posted Sep 24, 2019 - 13:33 BST
This incident affected: Account opening.