Issue with account opening
Incident Report for Monese
Resolved
This issue is now resolved.
Posted Mar 23, 2020 - 06:37 GMT
Monitoring
A fix has been implemented and we are monitoring the situation. We apologize for any inconvenience this may have caused.
Posted Mar 22, 2020 - 20:57 GMT
Identified
We have identified the problem and implemented a fix for this issue
Posted Mar 22, 2020 - 20:53 GMT
Update
We’re currently investigating a technical issue with one of our partners, which is affecting account opening for some customers. If you already have a Monese account, you won’t be affected. We’re working to fix this as soon as possible!
Posted Mar 22, 2020 - 17:54 GMT
Update
We are continuing to investigate this issue.
Posted Mar 22, 2020 - 17:53 GMT
Investigating
We are currently investigating this issue.
Posted Mar 22, 2020 - 17:12 GMT
This incident affected: New Account Opening.