Support channels down due to HelpDesk provider outage
Incident Report for Monese
Resolved
The issue has been resolved and our email and phone support is now fully operational.
Posted about 2 months ago. Nov 29, 2018 - 12:30 GMT
Monitoring
Our Helpdesk supplier has fixed the issue affecting out phone and email support channels. We are closely monitoring the results.
Posted about 2 months ago. Nov 29, 2018 - 11:50 GMT
Investigating
Our phone and email support is not fully operational due to an outage on the supplier side. Customers are encouraged to contact support over the in-app chat function during this outage.
Posted about 2 months ago. Nov 29, 2018 - 11:02 GMT
This incident affected: Account Help and Support.