Delays in Account Opening
Incident Report for Monese
Resolved
We are pleased to confirm that the issue has been fixed and the incident is now closed. We regret any inconvenience caused by the issue.
Posted about 1 month ago. Aug 07, 2019 - 07:36 BST
Investigating
We are currently investigating some delays in account opening due to technical issues. We will provide further updates shortly and apologise for any inconvenience caused.
Posted about 1 month ago. Aug 06, 2019 - 22:11 BST
This incident affected: New Account Opening.